[Schan-user] Eigene Dateien dauerhaft umbiegen

Hans-Dietrich Kirmse hd.kirmse at gmx.de
Don Aug 9 11:18:06 CEST 2012


Hallo Wolfgang,

 > Hallo Arkturianer,

ich antworte mal, auch wenn ich kein Arkturianer mehr bin.

Am 09.08.2012 10:08, schrieb Wolfgang See-Metz:

> Alle Clients (XP) sind hier bereits lange aufgestellt und haben hier mittlerweile als Notlösung
> einen allgemeinen lokalen Zugang.

Wieso ist das eine Notlösung für dein angegebenes Problem? - ist mir 
völlig unklar.

> Jetzt möchte ich, dass alle Domän-Nutzer automatisch mit den "Eigenen
> Dateien" auf "U:\Profile\WinXP\Eigene Dateien" (oder so ähnlich) umgeleitet werden.
>
> Ich habe nun schon mehrfach mit der logon.bat und ntconfig.pol experimentiert:
>
> In der logon.bat mit dem Eintrag
> "regedit /s Profile.reg" usw.
> (nach Anleitung http://arktur.de/Wiki/index.php?title=Client:Windows#Verfahren
>   - Vorschlag von Christoph Eberhardt).
>
> Das klappte leider immer nur mit der jeweils 2. Anmeldung - also nach der 1. Abmeldung

Das ist völlig richtig und auch logisch.

> - warum auch immer.

weil du die einträge in der Registry änderst - weiter nichts. Du löst 
keine Aktion aus, die z.B. ein Verzeichnis anlegt oder gar irgendwelche 
Dateien dann dahin kopiert. diesen Kopierprozess übernimmt 
dankenswerterweise Windows, nämlich bei der Abmeldung, denn da wird ja 
zurück auf den Server kopiert und windows schaut ja noch, wohin es 
kopieren muss und nimmt demzufolge den Eintrag aus der Registry. Das 
kann gar nicht anders sein.

> Besser schien mir das Anlegen einer ntconfig.pol zu sein.
> Mit entsprechender ADM-Datei konnte ich die "Eigenen Dateien" sofort umbiegen.

das kann ich überhaupt nicht verstehen. Die Einträge der ntconfig.pol 
werden ja erst nach der Abarbeitung der logon.bat in die Registry 
eingespielt - hat damit also die höhere Priorität. Auch hier wird 
keinerlei Kopieraktion etc. ausgelöst.

> Leider fehlten daraufhin alle Netzlaufwerke außer U:.

Bei mir ging das mit der config.pol problemlos. Habe aber die Doku nicht 
mehr. (war jahrelang auf dem Th. Bildungsserver)

> Ich vermute, dass irgendein Fehler verhindert, dass net use... dann richtig ausgeführt wird?

also die Anleitung im Wiki (siehe angegebenen Link) ist okay.
Aber was du gemacht hast - ???

> Wer kann helfen?

Wenn du mal ein paar brauchbare Informationen bereitstellen würdest, um 
deine Installation / Modifikation nachvollziehen zu können, dann könnten 
dir hier sehr viele helfen (mich eingeschlossen).

Viele Grüße
Hans-Dietrich

_______________________________________________
schan-user mailing list
schan-user at listserv.heise.de
http://www.heise.de/bin/newsletter/listinfo/schan-user